Couche compatibilité ieee1394 pour Fedora 8

Depuis Fedora 7 et l'utilisation de la pile firewire juju, certains périphériques (ohci 1.0) et autres bibliothèques (libdc1394) ne fonctionnent plus correctement avec Fedora... Voici une méthode pour installer l'ancienne pile ieee1394 avec Fedora 8. sans avoir à recompiler le kernel ni remplacer ces bibliothèques.
Since Fedora 7 and the new firewire stack (juju) some devices (with ohci 1.0) and others libraries (libdc1394) don't work as expected with Fedora... Here is a HOWTO to install the old ieee1394 stack with Fedora 8 without the need to recompile the kernel neither to replace official libraries...

Pour installer le dépôt kwizart pour Fedora 8 ( en x86 et x86_64 )

 su -
 rpm -ivh http://rpms.kwizart.net/kwizart-release-8.rpm
 yum --enablerepo=kwizart-testing install kmod-ieee1394 compat-libraw1394
 reboot

Il faut obligatoirement redémarrer pour que les bons modules soient chargés. Si lors du reboot, le module raw1394 n'est pas chargé, il faut faire

 su - 
 modprobe raw1394

Lorsque vous utilisez Fedora x86_64, il est possible que vous deviez installer manuellement la version compat-libraw1394.i386 (ou alors désinstaller la version i386 )

Si vous utilisez vlc, il est possible d'obtenir le plugins de contrôle firewire libdc1394 (Attention, vous devez utiliser le dépôt livna puisque je suis le mainteneur de ce paquet sur ce dernier).

 yum --enablerepo=kwizart-testing install vlc-plugins-dc1394
 exit
 vlc -list -vvv --no-plugins-cache |grep 1394

Cette dernière commande permet de reconstruire le cache de vlc et de vérifier que le plugin est bien disponible...

Je vais essayer de voir si d'autres modules peuvent être compilés pour utiliser libdc1394 (mplayer , avidemux voire cinelerra)

Commentaires

1. Le samedi, novembre 24 2007, 12:28 par Georges de Sablet

Bonjour,
félicitations pour cet ajout, mais ne serait-il pas possible d'avoir la même chose pour fedora7, ce qui éviterait de changer de version en permanence ?
Merci